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ActionGrid Error Message: Unable to Create/Update Fields (AccountID) or Name ID Value of Incorrect Type

ERROR MESSAGE

Unable to create/update fields: AccountID. Please check the security settings of this field and verify that it is read/write for your profile or permission set.

Or:

Name ID: id value of incorrect type.

CAUSE

When attempting to create tasks inline in a related list ActionGrid, the grid may refresh and you can lose data that you entered. You may receive the error messages listed above. These errors and loss of data are caused by an issue with Task Who IDs and What IDs. When Person Accounts are active, tasks can treat the Foreign Key lookup from Accounts to Tasks as a WhoID.

WHAT TO DO

A simple workaround is to modify the Visualforce Page Markup of the related list to use a WhatID. Follow these steps:

  1. In Salesforce, click Setup.
  2. In the App Setup area, click Develop and click VisualForce Pages.
  3. Locate the VisualForce page and click its Label link.
  4. Click Edit.
  5. Click the Visualforce Markup tab.
    • For a single related list Visualforce page:
      • Find the value FKName="WhoId" or FKName="<ObjectId>".
      • Change the value to FKName="WhatId".
    • For a MultiTab Visualforce page:
      • Find the Tasks tab in the <li>...</li> block of tags, and note the position in the list.
      • Find the same position in the <div>...</div> block of tags.
      • In that DIV section, replace FKName = “AccountId” or FKName = “WhoId” with FKName=”WhatId”.
  6. Click Save to apply the change.